Asus A7V and no DMA

4 replies [Last post]
mike velte
Offline
Joined: Sep 6 2000

I am Trying to set a church up with a video editing pc, but cant get DMA enabled

for Primary IDE/ATA controller that has one Maxtor quantum fireball 30

gig hd.
Asus A7V/Athlon 1ghz/256/W2000
Initially the DOS screen showed the hd as UDMA 5 but Windows as PIO. The

bios would let not me change the udma to 4 without changing AUTO to USER.

Then
I put SP2, DX8, DX8a, Via 4.34 and flashed the bios with a week old

version from asus. The cable is 80 wire.
Still no joy...the bios will now let me set UDMA to 4,PIO to 0(5 is not

available), DOS screen shows UDMA 4.

Bomag
Offline
Joined: Aug 15 2000

Is the UDMA 5 patch in SP2? I am not certain.

Otherwise set the disk to report itself as UDMA 4 and see what W2K detects it as.

mike velte
Offline
Joined: Sep 6 2000

Thanks Bomag, I even tried UDMA 3. The patch is in SP2.

andrewh
Offline
Joined: Oct 4 1999

Mike,

I am sure this si a dumb suggestion but you did write "Primary IDE controller".

Have you tried putting the drive on the Promise controller. The A7V (vanilla) does not support UDMA5 on its primary or secondary controllers, only on the two additional ones provided by the Promise controller.

Andrew

bcrabtree
Offline
Joined: Mar 7 1999

LOTS of motherboards do not work in completely standard ways.

It is quite possible, for instance, that DMA is controlled not from within Win2K but by a utility that was (or should have been) installed when you ran the motherboard setup program.

Peter Wells phoned me only yesterday reporting that a Win2K installation on one of his machines (also with SP2) offered no DMA options, but on my suggestion did look (and find) a motherboard utility had been installed in Programs.

Oh, and no patches are needed for SP2 to recognised ATA/100 (ie Mode 5).

Bob C