Maxtor 27Gb UDMA66

2 replies [Last post]
neil
Offline
Joined: Apr 17 1999

Upgrade fever hit again and I replaced my Maxtor 13Gb UDMA33 video capture drive with one of the above (DABS £244). Fdisked/formatted no probs; start up Win95(OSR2) and up pops error message:
"a child device connected to your parent device(standard dual PCI hard disk controller) is using compatibility mode drivers. This configuration is not supported, and system is halted."
On rebooting into safe mode, the only way the computer (Abit BH6, 128 Mb, DV300, TNT graphics) will function is if the drive is set in BIOS as PIO mode4. OK the drive is fast enough for DV capture but why can't I have UDMA, like my old Maxtor?
Any ideas?
Thanks
Neil S

bcrabtree
Offline
Joined: Mar 7 1999

If this is an ATA66 drive then it may be that the (not so new) bios of your PC doesn't recognise it. If the drive doesn't report itself as an ATA33 drive, then the Bios will think it's an old drive, and therefore not allow it to run as an Ultra ATA drive.

This has been a problem with IBM's ATA66 HDDs, which is overcome by a DOS utility that can get the drive to report itself as an ATA33 model (and, of course, switch back to ATA66 at a later date).

Perhaps there is a utility on Maxtor's website that does the same job.

Bob C

neil
Offline
Joined: Apr 17 1999

Bob, thanks- had already downloaded the Abit BH6 BIOS upgrade and flash utility, thinking that was the problem, but didn't have the courage to do it, this being the only computer at home with a net connection. Have now flashed the BIOS and everything is Hunky-Dory. Miro Expert reports HD speeds of 18-20 Mb/sec.
Whoopee!
Cheers
Neil S